Search not working.
Incident Report for Watu
Resolved
The search outage was resolved around 09:45 UTC.
We apologise for the trouble.
Posted Dec 08, 2014 - 10:17 UTC
Investigating
From around 05:30 UTC, staffer search has been down.
Please bear with us while we investigate the problem.
Posted Dec 08, 2014 - 07:59 UTC