Geocoding search is down
Incident Report for Watu
Resolved
Geographic search is functioning normally again.
Posted Apr 11, 2016 - 16:05 UTC
Investigating
Geographic search for staffers and job locations is currently down.
Our geocoding provider seems to be experiencing an outage - we are failing to connect to their servers.
We are still investigating the issue in more detail.
Posted Apr 11, 2016 - 14:45 UTC